В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mrflotov
mrflotov
16.02.2023 16:26 •  Информатика

Написать программу, находяшую сумму и произведение цифр четырехзначного числа

Ответ:
ШкОлА1337228
ШкОлА1337228
10.10.2020 03:20

var

   a, s, p : integer;

   

begin

   p := 1;

   repeat a := ReadInteger('введите 4-х значное число: ') until (a > 999) and (a < 10000);

   while a > 0 do begin      

       s += a mod 10;

       p *= a mod 10;

       a := a div 10;

   end;

   writeln('сумма ', s);

   writeln('произведение ', p);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?