В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Maks170104
Maks170104
25.03.2023 01:22 •  Информатика

Паскаль абс.составить программу для решения следующей : известный пират флинт положил некоторую сумму s в банк под 3% годовых. выведите на экран, через сколько лет сумма превысит 1,5s. начальное значение s вводится с клавиатуры. решать через while

Ответ:
AlinaWinter2015
AlinaWinter2015
10.10.2020 02:50

program flint;

var s, s2, y: real;

begin;

readln(s);

s2 := s * 1.5;

while s < s2 do begin;

s := s * 1.03;

y := y + 1;

end;

writeln(y)

end.

0,0(0 оценок)
Ответ:
doblezor
doblezor
10.10.2020 02:50

Program n_1;

var s, m: real; n:integer;

begin

 read(s);

 n:=0; m:=s;

 while (m<=1.5*s) do begin

   m:=m*1.03;

   n:=n+1;

 end;

 writeln(n);

end.

Честно говоря, решение тут вообще не зависит от S. Всегда выводится одно и то же число - 14

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?