В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Нужно в паскале. напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. в конце работы программы на экран выводится сумма и произведение введенных чисел (не считая 0).

Ответ:
kisel2014
kisel2014
10.10.2020 01:53

Program n_1;

var a, b, n: double;

begin

   read (n);

   a:=n; b:=n;

   if n<>0 then read (n);

   while (n<>0) do begin

       a:=a+n;

       b:=b*n;

       read(n);

   end;

   writeln('Сумма чисел равна ', a:0:10, ' а их произведение ', b:0:10);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?