В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ДианаDi1111
ДианаDi1111
10.02.2022 11:00 •  Информатика

Напишите программу алгоритм евклида для вычисления наибольшего общего делителя двух натуральных чисел, формулируется так: нужно заменять большее число на разность большего и меньшего до тех пор, пока одно из них не станет равно нулю; тогда второе и есть нод. напишите программу, которая реализует
этот алгоритм.входные данныевходная строка содержит два числа, разделённые пробелом – a и b .выходные данныепрограмма должна вывести в одной строке два числа: сначала наибольший общий делитель двух введённых чисел, а затем – количество шагов цикла, которые были выполнены.примерывходные данные14
21выходные данные7 3входные данные171 3534выходные данные57 23язык pyton tutor

Ответ:
SofiaLimon
SofiaLimon
10.10.2020 01:48

def gcd(a, b):

   y = 0

   while a != b:

       y += 1

       if a > b:

           a = a - b

       else:

           b = b - a        

   print("%s%s" % (a, y))

string = str(input())

args = string.split(' ')

a, b = int(args[0]), int(args[1])

gcd(a, b)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?