В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
pudgebude
pudgebude
02.08.2022 04:39 •  Информатика

Составить программу цикла for в которой выведется на экран сумма всех четных чисел в диапазоне от 50 до 120, и написать программу в которой в этом же диапазоне считала сумму всех чисел.

Ответ:
sonek987
sonek987
10.10.2020 01:11

var

   s1 : integer; // сумма четных чисел

   s2 : integer; // сумма всех чисел

   

begin

   for var i := 50 to 120 do begin

       if i mod 2 = 0 then s1 += i;

       s2 += i;

   end;

   writeln('сумма четных чисел = ', s1);

   writeln('сумма всех чисел = ', s2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?