В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
idjrglkuahregklha
idjrglkuahregklha
21.06.2020 00:53 •  Информатика

С! нужно. составьте программу: дана таблица вещ таб b[1: 7]. замените каждый отрицательный элемент нулем. дана таблица вещ таб с[1: 10]. найдите максимальный элемент таблицы.

Ответ:
mregor3
mregor3
10.10.2020 01:06

Первая часть

Program n_1;

var i:integer; B: array[1..7] of real;

begin

   for i:=1 to 7 do begin

       read(B[i]);

       if B[i]<0 then B[i]:=0;

   end;

   for i:=1 to 7 do write(B[i]:0:5, ' ');

end.

Вторая часть

Program n_2;

var i:integer; a:real; C: array[1..10] of real;

begin

   for i:=1 to 10 do begin

       read(C[i]);

   end;

   a:=C[1];

   for i:=1 to 10 do if (C[i]>a) then a:=C[i];

   writeln(a:0:10);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?