В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ordal2
ordal2
25.04.2020 03:06 •  Информатика

Составьте программу в паскаль для вычисления: найти радиус окружности, описанной около правильного n-угольника со стороной а

Ответ:

var

   n : integer; // количество сторон (углов)

   a : integer; // длина стороны

   

begin

   write('введите количество сторон n= ');

   readln(n);

   write('введите длину стороны a= ');

   readln(a);

   writeln('радиус описанной окружности R=', a/2*(sin(pi/n)));

end.

не забываем что паскаль считает в радианах и формула расчета соответственная...

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?