В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
toshakalashnik
toshakalashnik
17.01.2022 02:29 •  Информатика

Написать программу, которая выводит целые числа в промежутку от 1 до 50, кратные двенадцати и считает их количество, сумму и произведение.

Ответ:
dok12369
dok12369
09.10.2020 23:50

var amount, sum, multi, i: integer;

begin

   amount:= 0;

   sum:= 0;

   multi:= 1;

   for i:=1 to 51 do begin

       if i mod 12 = 0 then begin

           writeln(i);

           amount:= amount + 1;

           sum:= sum + i;

           multi:= multi * i;

       end;

   end;

   writeln(amount, ' ', sum, ' ', multi);

end.

amount = 0

sum = 0

multi = 1

for i in range(1, 51):

   if i % 12 == 0:

       print(i)

       amount += 1

       sum += i

       multi *= i

print(amount, ' ', sum, ' ', multi)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?