В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hoylli333
hoylli333
02.06.2023 04:17 •  Информатика

Составьте программу ,заполнения массива a[i, j] нулями и единицами в форме ромба

Ответ:
Этоясказал
Этоясказал
09.10.2020 23:46

var

 A: array [1..9, 1..9] of Integer;

 i, j: Integer;

begin

 WriteLn ('Массив:');

 for i := 1 to 9 do begin

   for j := 1 to 9 do begin

     if Abs (i - 5) + Abs (j - 5) <= 3 then

       A [i, j] := 1

     else

       A [i, j] := 0;

   end;

 end;

 for i := 1 to 9 do begin

   for j := 1 to 9 do begin

     Write (A [i, j], ' ');

   end;

   WriteLn;

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?