В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kitsrarr
kitsrarr
05.04.2021 03:12 •  Информатика

Задан двумерный целочисленный массив в из n строк и m столбцов (1 ≤ n, m ≤ 10). составить программу, которая организует двумерный массив, элементы главной диагонали которого равны соответствующим элементам исходного массива, а остальные элементы равны нулю.

Ответ:
577656
577656
09.10.2020 23:43

const n=6; m=n;

var b:array[1..n,1..m] of integer;

i,j: integer;

begin

writeln('Исходный массив:');

for i:=1 to n do

begin

for j:=1 to m do

 begin

 b[i,j]:=random(90)+10;

 write(b[i,j]:4);

 end;

writeln;

end;

writeln('Полученный массив:');

for i:=1 to n do

for j:=1 to m do

 if i<>j then b[i,j]:=0;

for i:=1 to n do

begin

for j:=1 to m do write(b[i,j]:4);

writeln;

end;

end.

Пример:

Исходный массив:

 59  63  74  85  64  87

 59  86  48  66  68  44

 49  36  90  15  96  34

 44  52  81  83  57  53

 61  45  93  85  16  40

 17  68  11  43  84  96

Полученный массив:

 59   0   0   0   0   0

  0  86   0   0   0   0

  0   0  90   0   0   0

  0   0   0  83   0   0

  0   0   0   0  16   0

  0   0   0   0   0  96

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?