В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
daniil8092228
daniil8092228
08.06.2023 22:04 •  Информатика

Составить программу, которая подсчитывает сумму элементов массива, больших 50 и меньших или равных 80.

Ответ:
funnybotan2000
funnybotan2000
09.10.2020 23:15

var

 A: array [1..10] of Integer;

 i, s: Integer;

begin

 Randomize;

 WriteLn ('Массив:');

 for i := Low (A) to High (A) do begin

   A [i] := Random (100);

   Write (A [i], ' ');

 end;

 for i := Low (A) to High (A) do begin

   if (A [i] > 50) and (A [i] <= 80) then

     s := s + A [i];

 end;

 WriteLn;

 WriteLn ('Сумма элементов массива = ', s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?