В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
коала22
коала22
27.09.2020 06:23 •  Информатика

40 ! даны гипотенуза и катет прямоугольного треугольника. напишите программу для нахождения второго катета и площади треугольника.(информатика 8 класс)^^ заранее кансанмида()

Ответ:
Pyben
Pyben
09.10.2020 22:10

var a,b,c:real;

begin

readln(a,b);{a-gip b-kat}

c:=sqrt(sqr(a)-sqr(b));  {формула с^2=a^2-b^2}

writeln(c:0:0,'второй катет');

writeln(a*b/2:0:0,'площадь');

end.

0,0(0 оценок)
Ответ:
ГАТИНЫ
ГАТИНЫ
09.10.2020 22:10

Program PrTreug;


var a,b,c,s:real;


begin


readln(a,c);

//a и b-катеты, c-гипотенуза

b:=sqrt(sqr(a)-sqr(b));


writeln('Второй катет ->',b);


s:=(b*a)/2;


writeln('Площадь прямоугольного треугольника ->',s);


end.

Программа прикреплена в PascalABC.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?