В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Selch
Selch
04.05.2020 03:14 •  Информатика

Составьте программу, которая формирует массив, содержащий 12 случайных вещественных чисел от -1 до 3, и подсчитывает произведение всех отрицательных чисел. вывод - в столбец с двумя десятичными знаками

Ответ:
zhzdd
zhzdd
09.10.2020 22:03
PascalABC.NET 3.4.2, сборка 1978 (12.02.2019) program task31143948;const  N = 12;var  arr: array[1..N] of real;  Sum: real;begin  Sum := 1;  for var i := 1 to N do    begin      arr[i] := Random()*4 - 1;      Writeln(arr[i]:5:2);      if arr[i] < 0 then        Sum := Sum * arr[i]    end;  if Sum = 1 then    Write('ПРОИЗВЕДЕНИЕ = 0')  else    Writeln('ПРОИЗВЕДЕНИЕ = ', Sum:5:2);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?