В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Polina14041
Polina14041
30.12.2021 14:41 •  Информатика

Впаскале, через case of составить программу для начисления зарплаты согласно следующему правилу: если стаж работы сотрудника менее 5 лет, то зарплата 50$., при стаже работы от 5 до 15 лет — 100$., при стаже свыше 15 лет зарплата повышается с каждым годом на 10$, превышающем 30 лет она составляет 300$

Ответ:
skvortsovaasya
skvortsovaasya
09.10.2020 21:25

var

old:integer;

begin

writeln('Введите стаж');

readln(old);

case old of

0..4: writeln('50$');

5..15: writeln('100$');

16..30: writeln(100+(old mod 15)*10);

31..100: writeln('300$');

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?