В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
AliceRosen
AliceRosen
30.07.2020 08:53 •  Информатика

Паскаль abc вводится последовательность целых чисел n. найдите наибольший элемент последовательности не содержащий нулей. буду за

Ответ:
Pomidorka213
Pomidorka213
09.10.2020 20:28
Var i,n,s,max: integer;
k,h: string;
begin
max:=0;
writeln('Введите кол-во чисел');
readln(n);
for i:=1 to n do
begin
readln(s);
Str(s,k);
if pos('0',k)=0 then
begin
if s>max then
max:=s;
end;
end;
writeln(max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?