В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
илья1864
илья1864
05.08.2021 00:37 •  Информатика

Написать программу, которая вычисляет сумму цифр 5 -значного числа. язык паскаль.

Ответ:
katmoxie
katmoxie
09.10.2020 20:20

program v1;

var a,b,S,P: real;

begin

writeln ('Введите сумму чисел');

readln(a);

writeln ('Введите произведение чисел');

readln(b);

S:=a+b;

P:=a*b;

b:=-S-SQRT(SQR(S)-4*P);

a:=S-b;

writeln('1-е число равно ', a,'. 2-е число равно ', b);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?