В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ruslanamotul1510
ruslanamotul1510
27.06.2022 07:08 •  Информатика

Составить программу вычисления, w=b+(a-b): (c+1) a сумма положительный элементов массива b количество отрицательных элементов массива c произведение элементов массива с нечетными номерами полученные значения элементов a,b,c,w вывести на печать.

Ответ:
Самацвет
Самацвет
09.10.2020 20:11

const N=1000;

var K: array [1..N] of integer;

i,A,B,C: integer;

W: real;

begin

for i:=1 to N do K[i]:=random(101)-50;

A:=0;

B:=0;

C:=1;

for i:=1 to N do begin

if K[i]>0 then A:=A+K[i];

if K[i]<0 then B:=B+1;

if i mod 2<>0 then C:=C*K[i];

end;

W:=B+(A-B)/(C+1);

writeln(W);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?