В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Lubov080301
Lubov080301
27.06.2022 07:08 •  Информатика

Написать программу на паскале, которая выводит число a в обратном порядке

Ответ:
Браство
Браство
09.10.2020 20:11

Код к задаче: «Вывести число в обратном порядке - Pascal»

var x1,x2,h,i,s:integer;

begin

write('x1=');readln(x1);

write('h=');readln(h);

x2:=2*x1+h;

i:=2;

s:=x1+x2;

while i<=8 do

begin

 i:=i+1;

 x1:=x2;

 x2:=2*x1+h;

 s:=s+x2;

 if i=5 then writeln('Пятый элемент=',x2);

 if i=7 then writeln('Сумма=',s);

 if i=8 then write('Восьмой элемент=',x2);

end;

readln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?