В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vladimir1232
vladimir1232
27.04.2022 22:29 •  Информатика

24 1. составьте программу решения . дано трёхзначное число. вывести «да», если только его первая и третья цифры четные и «нет» в противном случае. 2. дано натуральное число. определить в нем максимальную нечетную цифру. 3. дан массив из 20 элементов, заполненный случайными числами из диапазона [-45; 55]. найти в нем сумму четных положительных элементов.

Ответ:
Diana17273839
Diana17273839
04.10.2019 15:40

1.

var

  a: integer;

 

begin

  readln(a);

  if ((a mod 10) mod 2 = 0) and ((a mod 100) mod 2 = 0) then writeln('да')

  else writeln('нет');

end.

2.

var

  a, max: integer;

 

begin

  readln(a);

  max : = -1;

  while a < > 0 do

  begin

    if ((a mod 10) mod 2 = 0) and ((a mod 10) mod 2 > max) then max : = (a mod 10) mod 2;

    a : = a div 10;

  end;

  if max < > -1 then writeln(max)

  else writeln('');

end.

3.

var

  mas: array[0..19] of integer;

  sum, i: integer;

begin

  randomize;

  sum : = 0;

  for i : = 0 to 19 do  

  begin

    mas[i] : = -45 + random(1 + 45 + 55);

    if (mas[i] mod 2 = 0) and (mas[i] > 0) then sum += mas[i];

  end;

  writeln(sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?