В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ислам406
ислам406
04.01.2022 15:24 •  Информатика

Напишите программу получения всех совершенных чисел из диапазона от 1 до написать через цикл while.

Ответ:
alina1749
alina1749
09.10.2020 19:51

var n,i,j,s,k:integer;

begin

write('Введите число: ');

readln(n);

i:=1;

while i <= n do  

begin

j:=1;

s:=0;

while j<i

do

if i mod j = 0 then

begin

s:=s+j;

j:=j+1;

end

else

j:=j+1;

if s=i then

begin

k:=k+1;

if k=1 then write('Совершенные числа из диапазона от 1 до ',n,': ');

write(i,'  ')

end;

i:=i+1

end;

if k=0 then write('Совершенных чисел в диапазоне от 1 до ',n,' нет');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?