В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
LizaLove200468
LizaLove200468
03.03.2022 06:15 •  Информатика

Составьте программу , которая формирует массив из 10 целых чисел значения которых лежат в интервале от - 10 до 10 ( [ 10: 10] ) . программа должна выводить на экран исходный массив затем преобразовать элементы массива , увеличивая в два раза положительные элементы , а для отрицательных элементы менять знак на противоположный . выведите на экран преобразованный массив . в паскале !

Ответ:
1039лчдвб
1039лчдвб
09.10.2020 19:28

const n=10;

var a:array[1..n] of integer;

i: integer;

begin

for i:=1 to n do

begin

a[i]:=random(21)-10;

write (a[i]:3,' ');

if a[i]>0 then a[i]:=a[i]*2;

if a[i]<0 then a[i]:=-a[i]

end;

writeln;

for i:=1 to n do write (a[i]:3,' ')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?