В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
fuhohejo
fuhohejo
12.04.2020 05:32 •  Информатика

Составить программу, которая вычисляет площадь треугольника заданного координатами своих вершин. используя формулу герона. вычисления расстояния между двумя точками оформить в виде процедуры или функции

Ответ:
Pikaduwert
Pikaduwert
09.10.2020 19:18

Попроси решение у одноклассников и просто поменяй название переменных. Я сам так всегда делаю

Решение

Program n1;

Procedure qwe(x1,x2,y1,y2:integer);

var a,b,c,p:real;

begin

a:= x2-x1;

b:= y2-y1;

c:= sqrt((a*a)+(b*b));

p:=(a+b+c)/2;

writeln(sqrt(p*(p-a)*(p-b)*(p-c)));

end;

var i,o,p,l:integer;

begin

read(i,o,p,l);

//Вводить в формате x1,x2,y1,y2

qwe(i,o,p,l);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?