В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
катя4003
катя4003
07.03.2023 08:51 •  Информатика

Pascalabc. составьте программу, которая формирует массив из 15 случайных целых чисел, каждое из которых находится в диапазоне от -10 до 10 и выводит на экран: а) максимальный элемент массива б) индекс максимального элемента массива

Ответ:
FlowerBlue17
FlowerBlue17
09.10.2020 19:07

program fantscrin;

 const n = 15;

 var a: array [1..n] of integer;

     i,max,max_i:integer;

Begin

 for i:=1 to n do

   a[i]:= random(21)-10;

 for i:=1 to n do

   write(a[i], '  ');

   

 max:=a[1];

 max_i:=1;

 for i:=2 to n do

   if (a[i]>max) then  

                 begin

                   max:=a[i];

                   max_i:=i;

                 end;

 writeln('');

 writeln('Элемент: ', max);

 writeln('Индекс: ', max_i);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?