В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Aylar06
Aylar06
21.02.2021 17:15 •  Информатика

Напишите программу, чтобы с её можно было найти наибольший общий делитель произвольных десяти целых двузначных чисел (на языке паскаль)

Ответ:
Kamilkamilka222
Kamilkamilka222
09.10.2020 18:47

на яве мог бы

0,0(0 оценок)
Ответ:
shasherina13ozz1hj
shasherina13ozz1hj
13.01.2024 05:32
Конечно! Вот программа на языке Паскаль, которая позволяет найти наибольший общий делитель произвольных десяти целых двузначных чисел:

```
program Наибольший_общий_делитель;
var
a, b, GCD, temp: integer;

function НОД(a, b: integer): integer;
begin
while b <> 0 do
begin
temp := b;
b := a mod b;
a := temp;
end;

НОД := a;
end;

begin
writeln('Введите два десятичных двузначных числа:');
readln(a, b);

GCD := НОД(a, b);

writeln('Наибольший общий делитель чисел ', a, ' и ', b, ' равен ', GCD);
end.
```

Теперь разберем программу шаг за шагом:

1. Здесь мы объявляем переменные: `a`, `b`, `GCD` и `temp`. `a` и `b` будут использованы для ввода двузначных чисел, `GCD` будет хранить значение наибольшего общего делителя, а `temp` будет использоваться для временного хранения значения при обмене.

2. Мы объявляем функцию `НОД`, которая будет использоваться для вычисления наибольшего общего делителя. В строчках 10-13 мы используем алгоритм Евклида - в цикле мы находим остаток от деления `a` на `b`, затем присваиваем `b` значение `a mod b` и `a` значению `temp`. Этот процесс повторяется, пока `b` не станет равным нулю. После этого `a` будет содержать наибольший общий делитель, и мы возвращаем это значение.

3. Затем мы просим пользователя ввести два десятичных двузначных числа. Это делается с помощью `readln`, где `a` и `b` будут получать значения, введенные пользователем.

4. Мы вызываем функцию `НОД` и присваиваем её результат переменной `GCD`.

5. Наконец, мы выводим результат на экран с помощью `writeln`, объединяя текст и значения переменных с помощью оператора `+`.

Вот и все! Теперь программа способна находить наибольший общий делитель произвольных двузначных чисел.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?