В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Anna2004Shevtsova
Anna2004Shevtsova
04.08.2021 18:19 •  Информатика

Написать программу. даны 10 оценок ученика по . найти средний . исправить оценки, которые < =3 на выше. вывести все 10 оценок на экран.

Ответ:
sirius2010
sirius2010
09.10.2020 18:41

java:

import java.util.Random;

int [] ocenki = new int [10];

Random rand = new Random ();

for( int i = 0; i < ocenki.length; i++){

   ocenki[i] = rand.nextInt(3+1) + 1;

   if (ocenki[i] <= 3) ocenki[i] = ocenki[i] + 1;

   System.out.print(ocenki[i] + "\t");

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?