Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
RADIUM24
08.09.2021 23:41 •
Информатика
Что-то подзабыл я pascal. написать программу в pascal, которая складывает последние 4 цифры любого задаваемого числа.
Ответ:
лис239
02.09.2020 15:49
Var a,s:integer;
begin
repeat readln(a) until a>9; // по условию число >9
s:=a mod 10; // забираем последнюю цифру
while a>9 do a:=a div 10; // вычеркиваем последнию цифру, пока а - двухзначное число
writeln(s+a mod 10) // теперь выводим сумму
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
artik269
09.04.2023 15:53
Минимизация уравнений: решите 1 вариант!...
Амбрела123
13.01.2022 15:21
На тему домбра на каз яз с переводом...
anastia15
07.04.2022 09:30
Вмассиве из 10 элементов, заполненного случайными числами из интервала от –15 до 15, найти одновременно наибольший и наименьший элементы массива....
машана1
21.06.2021 18:48
В чем ошибка в коде? Паскаль абс var e,a,i,FACTc,x,k,s,n: real; c:integer; begin write( Введите x ); readln(x); a:=x; c:=3; i:=1; FACTc:=1; repeat e:=power(x,c); repeat FACTc:=FACTc*i;...
irasurkova197
10.03.2023 16:41
Запишите по 2 суждения: 1. Из истории 2.из географии 3.из биологии 4. из математики 5. из русского языка 6. из литературы 7. из информатики С меня :) ПРОСТО ЛЕНЬ !!...
Аня3321
14.04.2021 03:43
Что не являетесь формой записи алгоритма...
polina11111334944849
09.08.2022 21:00
какой из объектов может является исполнителем? а)луна б)карта в)принтер г)книга...
ayskamaska
20.03.2023 07:32
Переведите числа в десятичную систему счисления.а) 1110001112;б) 1000110112;....
maryam124
26.10.2021 10:06
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 3 или кратных 5. Программа получает на вход количество чисел в последовательности,...
MCЯнуля
20.09.2021 01:08
З яких частин складається автономна нервова система?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
repeat readln(a) until a>9; // по условию число >9
s:=a mod 10; // забираем последнюю цифру
while a>9 do a:=a div 10; // вычеркиваем последнию цифру, пока а - двухзначное число
writeln(s+a mod 10) // теперь выводим сумму
end.