В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Petya109
Petya109
05.04.2023 14:43 •  Информатика

Составить программу, которая формирует массив из 27 случайный чисел от -10 дл 15 и нечетные числа заменяет на 3, остальные уменьшает в 3 раза в паскале

Ответ:
Columbos
Columbos
09.10.2020 15:45

const n=27;


var a:array [1..n] of integer;


i:integer;


begin


write('      Исходный массив: ');


for i:=1 to n do


begin


a[i]:=random(26)-10;


write(a[i]:3,' ');


if a[i] mod 2 <> 0 then a[i]:=3


else a[i]:=a[i]-3//уменьшает на 3,т.к. при уменьшении в 3 раза получается тип real, тут или второй массив создавать или взять a[i]:=a[i] div 3 (целочисленное деление)


end;


writeln;


write('Преобразованый массив: ');


for i:=1 to n do write(a[i]:3,' ')


end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?