В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Termenator73
Termenator73
02.02.2022 07:14 •  Информатика

Написать программу, которая проверяет следующий факт: все цифры данного четырехзначного числа n различны

Ответ:
1zoya
1zoya
09.10.2020 15:42

var n,a,b,c,d:integer;

begin

readln(n);

a:=n mod 10;

b:=(n div 10) mod 10;

c:=(n div 100) mod 10;

d:=n div 1000;

if((a-b<>0)or(c-d<>0)or(a-d<>0)) then writeln('Цифры введённого четырёхзначного числа различны') else

writeln('Цифры введённого четырёхзначного числа одинаковы');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?