В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ariiiiiaha
ariiiiiaha
21.07.2021 13:00 •  Информатика

Паскаль 90 уровень 9 класса 1.напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. программа должна вывести одно число — максимальное число, кратное 4 2.напишите программу, которая в последовательности натуральных чисел определяет кол-во чисел, кратных 4. программа должна вывести количество чисел, кратных 4. 3.напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. программа должна вывести одно число — сумму чисел, оканчивающихся на 4

Ответ:
00Лисичка00
00Лисичка00
09.10.2020 15:40

1.

var n,i,a,m:integer;

begin

m:=-1;

write ('Введите количество чисел в последовательности: ');

readln(n);

for i:=1 to n do

begin

write ('Введите число (больше -1): ');

readln(a);

if (a mod 4 = 0) and (a>m) then m:=a

end;

write('Максимальное число, кратное 4, равно ',m);

end.


2.

var n,i,a,k:integer;

begin

write ('Введите количество чисел в последовательности: ');

readln(n);

for i:=1 to n do

begin

write ('Введите число: ');

readln(a);

if a mod 4 = 0 then k:=k+1

end;

write('Количество чисел, кратных 4, равно ',k);

end.


3.

var n,i,a,s:integer;

begin

write ('Введите количество чисел в последовательности: ');

readln(n);

for i:=1 to n do

begin

write ('Введите число: ');

readln(a);

if a mod 10 = 4 then s:=s+a

end;

write('Сумма чисел, оканчивающихся на 4, равна ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?