В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Еннтпшдь
Еннтпшдь
09.12.2022 00:01 •  Информатика

Составьте программу, которая формирует массив из двадцати случайных целых чисел от -30 до 30 и подсчитывает количество четных элементов. на экран выводятся исходные массив и результат

Ответ:
zalehorosaj
zalehorosaj
09.10.2020 15:39

var a:array[1..20] of integer;

i,k: integer;

begin

write('Массив: ');

for i:=1 to 20 do

begin

a[i]:=random(61)-30;

if a[i] mod 2 = 0 then k:=k+1;

write (a[i]:3,' ')

end;

writeln;

write('Количество четных элементов ',k)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?