В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
logvlad9
logvlad9
30.04.2022 20:14 •  Информатика

Составьте программу, которая формирует массив из двадцати случайных целыъ от -15 до 15 и уменьшает в 3 раза числа, кратные 3, а остальные увеличивает в 2 раза

Ответ:
katenkaklimcuk
katenkaklimcuk
09.10.2020 15:38

var a:array[1..20] of integer;

i: integer;

begin

write(' Исходный массив: ');

for i:=1 to 20 do

begin

a[i]:=random(31)-15;

write (a[i]:3,' ')

end;

writeln;

write('Преобразованый массив: ');

for i:=1 to 20 do

begin

if (a[i] mod 3 = 0) then a[i]:=a[i] div 3

else a[i]:= a[i]*2;

write (a[i]:3,' ')

end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?