В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
стланка
стланка
08.01.2020 09:46 •  Информатика

Составьте программу которая формирует массив из 10 случайных чисел в диапазоне от 1 до 10 и вычисляет произведения элементов массива с нечестными значениями. на экран выводится исходный массив, массив с нечестными значениями и произведение.

Ответ:
4fhfhiukhriu
4fhfhiukhriu
09.10.2020 15:48

program fantscrin;



 const n = 10;



 var a: array [1..n] of integer;

     i,s:integer;

Begin

 for i:=1 to n do

   a[i]:= random(11)+1;

 for i:=1 to n do

   write(a[i], '  ');

 p:=1;

 for i:=1 to n do

   if (i mod 2 <> 0) then

                              begin

                                p:=p*a[i];

                                write(a[i], '  ');

                               end;

 writeln('');

 writeln('Произведение = ',p);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?