Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
ELB2
06.11.2020 06:22 •
Информатика
Напишите программу, которая решает : «дано целое число n. вывести на экран следующее за ним четное число». 12
Ответ:
annnnka16
21.08.2020 21:11
#include <iostream>
using namespace std;
int main() {
int n, i;
cin >> n;
i = n + 1;
if ( i % 2 == 0) {
cout << i;
}
else {
cout << n + 2;
}
return 0;
}
не оч красиво, но работает
0,0
(0 оценок)
Ответ:
makskos4444
21.08.2020 21:11
var n:integer;
begin
readln (n);
if n mod 2 = 0 then write(n+2)
else write(n+1)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ketrinkryt
13.12.2021 00:42
найдите два преимущества векторных изображений перед растровыми МНЕ НУЖНО ТОЧНЫЙ ОТВЕТЫ...
smasyanechka
03.06.2023 21:08
ОЧЕНЬ НУЖНОАрхивация файлов WinZip 1. Запустите WinZip 7. (Пуск Все программы 7-Zip 7 Zip File Manager). 2. В появившемся диалоговом окне выберите папку, в которой...
кпо123
03.06.2020 09:01
Запиши алгоритм действия....
naki4
18.11.2022 14:59
3. Что произойдет в результате выполнения функции А) Вычисление суммы чисел, равных 15, из диапазонаБ) Сравнение чисел, больше 15, из диапазона Al:A5.В) Вычисление...
Andrey21vek
03.02.2022 12:28
Запишите величины и их назначения , определяющие свойства обьектов : кирпичный дом- величина -значение...
gopina04vika
28.11.2021 16:41
Придумайте различные соединения в сеть четырех компьютеров-серверов.найдите обеспечивающий самый короткий маршрут передачи информации между двумя любыми пользователями....
Aliy251
01.05.2022 20:15
Составить программы в паскале : 1. сформировать одномерный массив из 9 вещественных чисел вводом с клавиатуры и выведите его на экран в обратном порядке. 2. сформируйте...
Kanapluhaaa
28.03.2022 02:24
Перечислите основные типы поисковых запросов?...
evamayninger20
24.05.2020 10:30
Вформе пятистрочника опишите объекты: «информация», «компьютер», «система» по плану: 1.слово. 2.два слова-характеристики (часто прилагательные). 3.три слова действия...
ніка2007
07.09.2022 11:18
Решить хотя бы одну из задач ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main() {
int n, i;
cin >> n;
i = n + 1;
if ( i % 2 == 0) {
cout << i;
}
else {
cout << n + 2;
}
return 0;
}
не оч красиво, но работает
var n:integer;
begin
readln (n);
if n mod 2 = 0 then write(n+2)
else write(n+1)
end.