В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу, которая будет вводить с клавиатуры положительные числа до тех пор, пока не будет введена -1. все числа должны записываться в один список и в конце работы программы из списка должны быть распечатаны сначала четные, затем не четные. на python

Ответ:
kurbanovkurban1
kurbanovkurban1
09.10.2020 14:03
Не очень корректное решение, но выводит вроде бы правильно

total = []
n = int(input())
total.append(n)
while n >= 0:
   n = int(input())
   total.append(n)
del total[-1]
for k in total:
   if k % 2 == 0:
       print(k)
   else:
       print(k)

Ссылка на код: https://pastebin.com/cRTRMS3L
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?