В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nacny2016
nacny2016
20.03.2022 19:39 •  Информатика

Нужен код на с++! : напишите программу, которая удваивает все буквы "z" в строке (нужно, чтоб строка изначально вводилась с клавиатуры) пример: было (zozo) стало (zzozzo)

Ответ:
VaDiMiR3000
VaDiMiR3000
09.10.2020 12:54

Держи -_-

#include <iostream>

#include <string>

using namespace std;

int main()

{

   string a;

   cin>>a;

   for(unsigned j=0;j<a.length();j++){

       if (a[j]=='z')  a.insert(++j,"z");

       

   }

   cout<<a;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?