В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
yanapetelyakp070y8
yanapetelyakp070y8
27.09.2021 01:51 •  Информатика

Определите среднее арифметическое чётных элементов массива a[1..10] написать программу в паскаль

Ответ:
eka04599
eka04599
09.10.2020 12:42

//Будем считать, что четные по значению

const

 n = 10;

var

 a: array[1..n] of integer;

 i, Sum, Count: integer;

begin

 Sum := 0;

 Count := 0;

 Randomize;

 for i := 1 to n do

 begin

   a[i] := Random(10);

   Write(a[i], ' ');

   if a[i] mod 2 = 0 then

   begin

     Sum := Sum + a[i];

     Count := Count + 1

   end

 end;

 

 Writeln;

 Write('Среднее арифметическое ' +  

       'четных чисел: ', Sum / Count)

end.

0,0(0 оценок)
Ответ:
yanaboss666
yanaboss666
09.10.2020 12:42

Здесь с четными, а там просто арефмитическое...


Var

m:array [1..100000] of integer;

k,i:integer;

Begin

k:=0;

randomize;

For i:=1 to 10 do

read(m[i]);

For i:=1 to 10 do begin

If m[i] mod 2=0 then

k:=k+m[i] else k:=k+0;end;

k:=k div 10;

writeln(k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?