В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Fleksander
Fleksander
19.05.2022 06:29 •  Информатика

Составить программу pascal. , хелп ! ввести с клавиатуры 7 чисел и определить: 1. сумму чисел кратных 5 2. сумму отрицательных чисел кратных к 3 3. количество положительных, четных чисел кратных 7

Ответ:
Ник6911
Ник6911
09.10.2020 12:13
Var
begin
for i:=1 to 7 do begin
write (A=); read (a);
end;
sk:=0;
s:=0;
c:=0;
for i:=1 to 7 do begin
if a mod 5=0 then begin
sk:=sk+a;
end;
if (a<0) and (a mod 3=0) then begin
s:=s+a;
end;
if (a>0) and (a mod 2=0) and (a mod 7=0) then begib
c:=c+1;
end;
end;
write (sk,s,c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?