В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DaniilF3001
DaniilF3001
16.10.2022 14:12 •  Информатика

5. дан двумерный массив целых чисел. составить программу, которая определяет, есть ли в некотором столбце массива хотя бы один элемент, кратный заданному числу.

Ответ:
Mona228
Mona228
09.10.2020 12:12
PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var (m, n) := ReadInteger2('Количество строк и столбцов в массиве:');

 Writeln('*** Исходный массив ***');

 var a := MatrRandom(m, n, -99, 99);

 a.Println(4);

 Writeln(4 * a.ColCount * '-');

 var nCol := ReadInteger('В каком столбце ищем?');

 var C := ReadInteger('На кратность чему проверить?');

 if a.Col(nCol - 1).Any(t -> t mod C = 0) then

   Writeln('Есть такие элементы')

 else Writeln('Таких элементов нет')

end.


5. дан двумерный массив целых чисел. составить программу, которая определяет, есть ли в некотором ст
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?