Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
alinkaalekseev1
01.11.2021 23:12 •
Информатика
Как посчитать в массиве количество подряд идущих элементов равных самому этому элементу? то есть если дан массив 0 2 2 0 3 3 3 0 то нужно вывести 2 так как две двойки идут подряд и три тройки идут подряд паскаль или с++
Ответ:
AliceandCat
09.10.2020 11:49
#include <iostream>
#include <algorithm>
using std::cout;
using std::cin;
int main()
{
int sizeArr, input;
cout << "enter size arr: "; //размер массива
cin >> sizeArr;
int arr[sizeArr];
cout << "enter arr: ";
for(int i = 0; i < sizeArr; i++)
{
cin >> input;
arr[i] = input;
}
for(int i = 0; i < sizeArr; i++)
{
if(i == arr[i])
{
cout << arr[i] << " ";
}
}
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Nanko11
12.03.2022 02:28
Напишите на алгоритмическом языке, работаем в программе ! 1)дана длина ребра куба. найти площадь грани, площадь полной поверхности и объем этого куба. 2)известна...
Lol11111111000
07.03.2020 12:42
Эргономика кай жылы гылым ретинде...
NHatynceva
12.01.2022 07:52
1. Определите значение переменной a после выполнения данного алгоритма: a := 3b := 7b := 9+a*ba := b/5*a2. Запишите значение переменной s, полученное в результате...
ekserukhova16
30.04.2021 13:12
ДЕСЯТИЧНОЕ число 159 в ДВОИЧНОЙ системе, в восьмеричной, в шестандцатеричной С РЕШЕНИЕМ в столбик деление, умножение и вычитание,...
SabrinaSirotina
27.03.2023 03:54
Доделайте таблицу заполните поля со знаком: ? ...
Kobrasmary
31.12.2020 06:31
Напишите программу на языке программирования C ++, которая будет реализовывать следующие действия: 1. Требовать ввести 2 целых числа. С цикла отобразите числа от...
nikitaevaoa
02.05.2023 08:08
Які властивості має команда в середовищі scratch...
Xafe456
23.07.2021 21:15
Напишите программу обмена сомов на доллары и евро в Python...
чина22
20.01.2022 12:52
Синформатикой ( , с блок схемами и самой программой) 1.предположим, фирма заработала какую-то сумму денег- эту сумму запросите у пользователя. по законодательству...
marisa10
16.05.2020 06:30
Одна из сторон прямоугольника равна 37 см, а периметр в 6 раз больше второй его стороны. найдите вторую сторону....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <algorithm>
using std::cout;
using std::cin;
int main()
{
int sizeArr, input;
cout << "enter size arr: "; //размер массива
cin >> sizeArr;
int arr[sizeArr];
cout << "enter arr: ";
for(int i = 0; i < sizeArr; i++)
{
cin >> input;
arr[i] = input;
}
for(int i = 0; i < sizeArr; i++)
{
if(i == arr[i])
{
cout << arr[i] << " ";
}
}
return 0;
}