В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
никва1
никва1
22.10.2021 03:03 •  Информатика

Составьте программу(в паскале), которая заполнит массив a[1..16]случайными целыми числами в диапазоне от -20 до 20, выводит на экран исходный массив, затем преобразовывает его, увеличивая в 2 раза все числа,кратные 5, а остальные уменьшает на 10. затем выводит на экран преобразованный массив.

Ответ:
оффЛис
оффЛис
09.10.2020 11:13

const n=16;

var a:array [1..n] of integer;

i:integer;

begin

for i:=1 to n do a[i]:=random(41)-20;

writeln('Исходный массив: ');

for i:=1 to n do write(a[i]:5);

writeln;

for i:=1 to n do

if a[i] mod 5 = 0 then a[i]:=a[i]*2 else a[i]:=a[i]-10;

writeln('Преобразованный массив: ');

for i:=1 to n do write(a[i]:5)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?