В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Syrtou
Syrtou
16.07.2022 05:50 •  Информатика

Написать программу в паскале. ввести n чисел. найти первое максимальное число и его номер.

Ответ:
bryleev99
bryleev99
17.08.2020 06:46
PascalABC.NET 3.4.2, сборка 1881 от 19.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ReadArrReal('Вводите:', ReadInteger('Количество чисел?'));

 var imax := a.IndexMax;

 Writeln('Первое максимальное число ', a[imax],

     ' имеет номер ', imax + 1)

end.

ПримерКоличество чисел? 5Вводите: 14 2.17 15.2 8 15.2Первое максимальное число 15.2 имеет номер 3
0,0(0 оценок)
Ответ:
Мэй15
Мэй15
17.08.2020 06:46

var n,i,m,k,a: integer;

begin

write ('Введите количество чисел: ');

readln (n);

write ('Введите число: ');

readln (a);

m:=a;

k:=1;

for i:=2 to n do

begin

write ('Введите число: ');

readln (a);

if a>m then

begin

m:=a;

k:=i

end

end;

writeln ('Первый максимальный элемент ',m,' и его номер ',k)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?