В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ЯМС
ЯМС
03.02.2021 16:20 •  Информатика

Напишите программу ,которая в последовательности натуральных чисел находит среднее арифметическое чисел ,кратных 6,или сообщает ,что таких чисел нет (выводит '' no'').программа получает на вход натуральные числа, количество введённых чисел неизвестно ,последовательность чисел заканчивается числом 0 ( 0-признак окончания ввода ,не входит в последовательность ) .количество чисел не превышает 10 .введённые числа не превышает 300. программа должна вывести среднее арифметическое чисел,кратных 6,или вывести "no'' если таких чисел нет . значение выводить с точностью до десятых.

Ответ:
Владимир328
Владимир328
11.08.2020 10:42
#include <bits/stdc++.h>
using namespace std;

int main() {
double sum = 0;
double n = 0;
while (true) {
int x;
cin >> x;
if (x == 0) break;
if (x % 6 == 0) {
++n;
sum += x;
}
}
if (n == 0) cout << "NO" << endl;
else cout << (sum / n) << endl;
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?