В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
герман136
герман136
09.09.2022 05:35 •  Информатика

Дан целочисленный массив а[n]. заменить все элементы массива, являющиеся простыми числами, на максимальное значение элементов массива. написать программу на с++

Ответ:
olesyapetrova8
olesyapetrova8
09.10.2020 10:38

#include <bits/stdc++.h>

using namespace std;

int n,a,mx = -1e6,b[10101];

bool check(int x) {

for (int i = 2; i <= sqrt(x); i++)

 if (x % i == 0) return 0;

return 1;

}

main () {

cin >>n;

for (int i = 1; i <= n; i++)

{

 cin >>b[i];

 mx = max(mx,b[i]);

}

for (int i = 1; i <= n; i++)

 if (check(b[i])) b[i] = mx;

for (int i = 1; i <= n; i++)

 cout <<b[i] <<" ";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?