В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
PicaChuShiK
PicaChuShiK
04.03.2023 09:12 •  Информатика

Написать программу которая будет определять делится ли число на 11 по признаку делимости на 11 на с++

Ответ:
Smile460
Smile460
10.09.2020 22:20

#include <iostream>


using namespace std;


int main(){

   int n;

   cout<<"n = ";

   cin>>n;

   

   int m=n,k=0;

   while(m){

       k++;

       m=m/10;

   }

   

   int arr[k];

   m=n;

   for(int i=0;i<k;i++){

       arr[i]=m%10;

       m=m/10;

   }

   

   int chet=0,nechet=0;

   for(int i=k-1;0<=i;i=i-2){

       nechet=nechet+arr[i];

   }

   

   for(int i=k-2;0<=i;i=i-2){

       chet=chet+arr[i];

   }

   

   if((chet==nechet)||(chet-nechet==11)||(chet-nechet==-11))

       cout<<"n%11=0"<<endl;

   else

       cout<<"n%11!=0"<<endl;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?