В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Kissi111
Kissi111
09.10.2021 09:53 •  Информатика

Напишите программу,которая считает сумму цифр введенного числа (паскаль) programи fr; var a, sum: integer; begin writeln ('введите число'); readln (a); while a< > 0 do begin sum: =sum+(a mod 10); a: =a div 10; end; writeln ('сумма цифр ',sum); end. почему используется вот такая запись ( что это значит ) - sum: =sum+(a mod 10) можно ли написать эту программу как то через другой цикл? ( если да,то напишите его) заранее

Ответ:
milanashavhalo1992
milanashavhalo1992
17.08.2020 06:42
A mod 10 - это остаток от деления а на 10 (последняя цифра числа, записанного в десятичной системе счисления)
можно по другому : сделать а типа string и, проходя по строке, прибавлять к сумме каждый символ строки (переведенный в цифру)
0,0(0 оценок)
Ответ:
Кирюха33333
Кирюха33333
17.08.2020 06:42

var a,s:integer;

begin

write ('Введите число: ');

readln(a);

repeat

s:=s+a mod 10;

a:=a div 10

until a=0;

write ('Сумма цифр: ',s);

end.

a mod 10 - эта операция определяет последнюю цифру числа (остаток от деления на 10)

первоначально sum равно 0

sum:=sum+(a mod 10) - накапливаем сумму всех цифр поочерёдно

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?