В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
stasgura
stasgura
05.04.2021 22:31 •  Информатика

Составить программу, в которой каждый элемент массива возводится в квадрат

Ответ:
ааnell714
ааnell714
09.10.2020 10:30
PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandom(ReadInteger('n='), -50, 50);

 a.Println;

 a.Transform(t -> t * t);

 a.Println

end.

Пример

n= 13

39 -13 48 8 34 -15 -13 -25 -43 -38 4 36 14

1521 169 2304 64 1156 225 169 625 1849 1444 16 1296 196

0,0(0 оценок)
Ответ:
grgrgrgrgrrhrrhrgrgr
grgrgrgrgrrhrrhrgrgr
09.10.2020 10:30

const n=10;

var a:array [1..n] of integer;

i:integer;

begin

for i:=1 to n do a[i]:=random(9)+1;

writeln('Исходный массив: ',a);

for i:=1 to n do a[i]:=a[i]*a[i];

writeln('Преобразованный массив: ',a)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?