В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составить программу сортировки 2-х переменных по убыванию, письменно. на pascal

Ответ:
dashkastroga
dashkastroga
09.10.2020 10:07

var a,b:real;

begin

readln(a,b);

if a>b then writeln(a,' ',b)  

else writeln(b,' ',a);

end.

0,0(0 оценок)
Ответ:
kiska510
kiska510
09.10.2020 10:07
PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var (a, b) := ReadReal2('Введите через пробел два числа;');

 if a < b then Swap(a, b); // a - всегда не меньше b

 Print('По невозрастанию:', a, b)

end.

Пример:Введите через пробел два числа; 3.6 10По невозрастанию: 10 3.6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?