В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Hhdhcnxh475366
Hhdhcnxh475366
28.04.2022 19:46 •  Информатика

Написать программу, которая проверяет, образуют ли элементы введенного с клавиатуры массива неубывающую последовательность отрицательных чисел.с++.

Ответ:
fcone
fcone
09.10.2020 07:56
#include <iostream>

int main()
{
int length;
bool flag=true;
std::cout<<"Введите длину массива: ";
std::cin>>length;
int *array=new int[length];
for (int i=0;i<length;i++)
{
std::cin>>array[i];
if (i>0)
if (array[i-1]>array[i])
flag=false;
if (array[i]>=0)
flag=false;
}
std::cout<<(flag?"true":"false");
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?