В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Мусор228
Мусор228
13.03.2022 11:57 •  Информатика

Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом «год», «года» или «лет». например, «21 год», «22 года», «25 лет». пример: введите возраст: 18 вам 18 лет. пример: введите возраст: 21вам 21 год. пример: введите возраст: 22вам 22 года. на c++ или паскаль

Ответ:
alan4ik1324
alan4ik1324
09.10.2020 07:33

program Vozrasr;



var


 AGE: integer;//Переменная возраста



begin


 writeln('Введите любое число от 1 до 120');


 Readln(AGE); //Ввод возраста


 if (AGE < 1) or (AGE > 120) then


begin


   writeln('ERROR!')


end


 else


 begin


   case AGE of  //для чисел от 11 до 20 создаем отд-ый кейс


     11..20: Writeln('ответ: Мне ', AGE, ' лет');


   Else    //иначе если они не входят в диапазон от [11..20], то выполняется второй кейс


     begin


       case AGE mod 10 of     //делим на 10 и получаем остаток =


         1: Writeln('ответ: Мне ', AGE, ' год');


         2..4: Writeln('ответ: Мне ', AGE, ' года');


         0, 5..9: Writeln('ответ: Мне ', AGE, ' лет');


       end;


     end;


   end;


end;


end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?