В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
katcornewa
katcornewa
27.10.2020 05:04 •  Информатика

Напишите программу, которая считывает с клавиатуры одно дробное число и выводит обратное ему. если при этом введённое с клавиатуры число меньше по абсолютной величине одной миллионной (в частности, если оно равно нулю), вывести вместо этого миллион. пример ввод вывод 0.5 2.0

Ответ:
PolliKirill
PolliKirill
21.08.2020 19:29
Var i,x: Integer;
n: Real;
begin
x:=1;
readln(n);
if n<>0 then
begin
while frac(n)<>0 do
begin
n:=n*10;
x:=x*10;
end;
if frac(x/n)=0 then writeln(x/n) else writeln(x,'/',n);
end else
writeln('1000000');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?